Horje
IE rendering badly - Thematic child theme of mine - Wordpress Solution
[Solved] - IE rendering badly - Thematic child theme of mine - Wordpress Solution
Try following codes
GDay, Having a bit of strife with a site I am building. I have created a child theme under Thematic and have had many changes requested along the way. Got a bit slack with checking it in other browsers and now I am paying for it :) I am using Linux and FF3.6 to build on. Looks good on there. Also having some issues with FF on XP rendering it differently. Main issue is centering and sizing the content within the container and the container within main divs. It is smaller and slumping slightly left in FF XP and IE7. Any clues would be great. I am making some real progress with my alignment issues now :) Messed up with css in 2cr-fixed.php and default.css. Still an issue with getting the custom font from myfonts to display at all. I did have it in Linux & Windows Firefox earlier. The site is at www.belindaherford.net/Sable/ Thanks

Solution - 1

Can you please post a link to your site here, so we can take a look at it? thanks I can see your custom fonts perfectly on FF 3.6.16, chrome 10 and IE9 on win7, not on ie6/7/8. Just to start, some tips: I can see 3 errors: 1) you missed somewhere in one of your css a closing "}" 2) http://belindaherford.net/Sable/?Kit-Light.css was not loaded because its MIME type, "text/html", doesn't match "text/css" MIME type. check your link tags 2) A JS error: $ is not defined. As you load a bunch of js libs (jquery and mootools for all), try not to use the $ shrotcut in jquery scripts (see http://belindaherford.net/Sable/wp-content/plugins/dropdown-menu-widget/js/include.js). Use jQuery instead. for ex: jQuery('blinds') instead of $('blinds') just to avoid conflicts with other JS libs trying to use $ variable And about custom fonts, take a look at [[LINK href="http://webfonts.info/wiki/index.php?title=%40font-face_support_in_Internet_Explorer"]]this[[/LINK]] about IE @font-face compatibility. ------------------------------------------------------------------------------------- ah ah, ok. It is 10.40 in the morning for me! As I can see at first, in your http://belindaherford.net/Sable/Kit-Light.css you have a question mark after eot url: .... .eot? and then you have redeclared the font-face as woof type just after the eot declaration. Try to use a conditional comment to load a ie specific css and cut and paste eot fonts declaration in it.

Date: 2022-10-21 05:15:34
Category: Wordpress
More for You